CVE-2021-3619

Low

Description

Rapid7 Velociraptor 0.5.9 and prior is vulnerable to a post-authentication persistent cross-site scripting (XSS) issue, where an authenticated user could abuse MIME filetype sniffing to embed executable code on a malicious upload. This issue was fixed in version 0.6.0. Note that login rights to Velociraptor is nearly always reserved for trusted and verified users with IT security backgrounds.

SeverityLow
CVSS3.5
Exploit probability—
ProductRapid7 Velociraptor
PublishedJul 22, 2021
First seenJul 22, 2021

How to fix

Update
  • rapid7 velociraptor0.6.0 or later

Affected products

ProductAffected versionsFixed in
rapid7 velociraptorv < 0.6.00.6.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.