CVE-2021-37626
Description
Contao is an open source CMS that allows you to create websites and scalable web applications. In affected versions it is possible to load PHP files by entering insert tags in the Contao back end. Installations are only affected if they have untrusted back end users who have the rights to modify fields that are shown in the front end. Update to Contao 4.4.56, 4.9.18 or 4.11.7 to resolve. If you cannot update then disable the login for untrusted back end users.
How to fix
- contao contao4.4.56, 4.9.18, 4.11.7 or later
- contao/core-bundle4.4.56, 4.9.18, 4.11.7 or later
- contao/contao4.4.56, 4.9.18, 4.11.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| contao contao | 4.4.0 ≤ v < 4.4.56, 4.9.0 ≤ v < 4.9.18, 4.11.0 ≤ v < 4.11.7, 4.0.0, 4.1.0, 4.2.0, 4.3.0, 4.5.0, 4.6.0, 4.7.0, 4.8.0, 4.10.0 | 4.4.56, 4.9.18, 4.11.7 |
| contao/core-bundlePackagist | 4.0.0 ≤ v < 4.4.56, 4.5.0 ≤ v < 4.9.18, 4.10.0 ≤ v < 4.11.7 | 4.4.56, 4.9.18, 4.11.7 |
| contao/contaoPackagist | 4.0.0 ≤ v < 4.4.56, 4.5.0 ≤ v < 4.9.18, 4.10.0 ≤ v < 4.11.7 | 4.4.56, 4.9.18, 4.11.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.