CVE-2021-39178
Description
Next.js is a React framework. Versions of Next.js between 10.0.0 and 11.0.0 contain a cross-site scripting vulnerability. In order for an instance to be affected by the vulnerability, the `next.config.js` file must have `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default or the instance is deployed on Vercel, the instance is not affected by the vulnerability. The vulnerability is patched in Next.js version 11.1.1.
How to fix
- vercel next.js11.1.1 or later
- next11.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | 10.0.0 ≤ v < 11.1.1 | 11.1.1 |
| nextnpm | 10.0.0 ≤ v < 11.1.1 | 11.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.