CVE-2021-39207

High

Description

parlai is a framework for training and evaluating AI models on a variety of openly available dialogue datasets. In affected versions the package is vulnerable to YAML deserialization attack caused by unsafe loading which leads to Arbitary code execution. This security bug is patched by avoiding unsafe loader users should update to version above v1.1.0. If upgrading is not possible then users can change the Loader used to SafeLoader as a workaround. See commit 507d066ef432ea27d3e201da08009872a2f37725 for details.

SeverityHigh
CVSS8.4
Exploit probability—
ProductFacebook Parlai
PublishedSep 10, 2021
First seenSep 10, 2021

How to fix

Update
  • facebook parlai1.1.0 or later

Affected products

ProductAffected versionsFixed in
facebook parlaiv < 1.1.01.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.