CVE-2021-39221

Medium

Description

Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Contacts application prior to version 4.0.3 was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Contacts application is upgraded to 4.0.3. As a workaround, one may use a browser that has support for Content-Security-Policy.

SeverityMedium
CVSS6.4
Exploit probability—
ProductNextcloud Contacts
PublishedOct 25, 2021
First seenOct 25, 2021

How to fix

Update
  • nextcloud contacts4.0.3 or later

Affected products

ProductAffected versionsFixed in
nextcloud contactsv < 4.0.34.0.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.