CVE-2021-39222
Description
Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy.
How to fix
- nextcloud talk10.0.7, 10.1.4, 11.1.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud talk | v < 10.0.7, 10.1.0 ≤ v < 10.1.4, 11.0.0 ≤ v < 11.1.2 | 10.0.7, 10.1.4, 11.1.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.