CVE-2021-39229

High

Description

Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is [here](https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359). The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove `apprise/plugins/NotifyIFTTT.py` to eliminate the service.

SeverityHigh
CVSS7.5
Exploit probability—
ProductNuxref Apprise
PublishedSep 20, 2021
First seenSep 20, 2021

How to fix

Update
  • nuxref apprise0.9.5.1 or later
  • apprise0.9.5.1 or later

Affected products

ProductAffected versionsFixed in
nuxref apprisev < 0.9.5.10.9.5.1
apprisePyPIv < 0.9.5.10.9.5.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.