CVE-2021-40110

High

Description

In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache James
PublishedJan 4, 2022
First seenJan 4, 2022

How to fix

Update
  • apache james3.6.1 or later
  • org.apache.james:james-server3.6.1 or later

Affected products

ProductAffected versionsFixed in
apache jamesv < 3.6.13.6.1
org.apache.james:james-serverMaven3.1.0 ≤ v < 3.6.13.6.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2021-40110 · Apache James · Dark Radar