CVE-2021-40331
Description
An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.
How to fix
- org.apache.ranger:ranger-hive-plugin2.4.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache ranger | 2.0.0 ≤ v ≤ 2.3.0 | — |
| org.apache.ranger:ranger-hive-pluginMaven | 2.0.0 ≤ v < 2.4.0 | 2.4.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.