CVE-2021-4034
Description
A local privilege escalation vulnerability was found on polkit's pkexec utility. The pkexec application is a setuid tool designed to allow unprivileged users to run commands as privileged users according predefined policies. The current version of pkexec doesn't handle the calling parameters count correctly and ends trying to execute environment variables as commands. An attacker can leverage this by crafting environment variables in such a way it'll induce pkexec to execute arbitrary code. When successfully executed the attack can cause a local privilege escalation given unprivileged users administrative rights on the target machine.
How to fix
Apply updates per vendor instructions.
CISA due date: Jul 18, 2022- polkit_project polkit121 or later
- siemens sinumerik_edge3.3.0 or later
- siemens scalance_lpe9403_firmware2.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| polkit_project polkit | v < 121 | 121 |
| redhat enterprise_linux_server_update_services_for_sap_solutions | 7.6, 7.7, 8.1, 8.2, 8.4 | — |
| redhat enterprise_linux | 8.0 | — |
| redhat enterprise_linux_desktop | 7.0 | — |
| redhat enterprise_linux_eus | 8.2 | — |
| redhat enterprise_linux_for_ibm_z_systems | 7.0, 8.0 | — |
| redhat enterprise_linux_for_ibm_z_systems_eus | 8.2, 8.4 | — |
| redhat enterprise_linux_for_power_big_endian | 7.0 | — |
| redhat enterprise_linux_for_power_little_endian | 7.0, 8.0 | — |
| redhat enterprise_linux_for_power_little_endian_eus | 8.1, 8.2, 8.4 | — |
| redhat enterprise_linux_for_scientific_computing | 7.0 | — |
| redhat enterprise_linux_server | 6.0, 7.0 | — |
| redhat enterprise_linux_server_aus | 7.3, 7.4, 7.6, 7.7, 8.2, 8.4 | — |
| redhat enterprise_linux_server_eus | 8.4 | — |
| redhat enterprise_linux_server_tus | 7.6, 7.7, 8.2, 8.4 | — |
| redhat enterprise_linux_workstation | 7.0 | — |
| canonical ubuntu_linux | 14.04, 16.04, 18.04, 20.04, 21.10 | — |
| suse enterprise_storage | 7.0 | — |
| suse linux_enterprise_high_performance_computing | 15.0 | — |
| suse manager_proxy | 4.1 | — |
| suse manager_server | 4.1 | — |
| suse linux_enterprise_desktop | 15 | — |
| suse linux_enterprise_server | 15 | — |
| suse linux_enterprise_workstation_extension | 12 | — |
| oracle http_server | 12.2.1.3.0, 12.2.1.4.0 | — |
| oracle zfs_storage_appliance_kit | 8.8 | — |
| siemens sinumerik_edge | v < 3.3.0 | 3.3.0 |
| siemens scalance_lpe9403_firmware | v < 2.0 | 2.0 |
| starwindsoftware command_center | 1.0 | — |
| starwindsoftware starwind_virtual_san | v8 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.