CVE-2021-40369

Medium

Description

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce plugin, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.0 or later.

SeverityMedium
CVSS6.1
Exploit probability—
ProductApache Jspwiki
PublishedNov 24, 2021
First seenNov 24, 2021

How to fix

Update
  • apache jspwiki2.11.0 or later
  • org.apache.jspwiki:jspwiki-main2.11.0 or later

Affected products

ProductAffected versionsFixed in
apache jspwikiv < 2.11.02.11.0
org.apache.jspwiki:jspwiki-mainMavenv < 2.11.02.11.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.