CVE-2021-40525
Critical
Description
Apache James ManagedSieve implementation alongside with the file storage for sieve scripts is vulnerable to path traversal, allowing reading and writing any file. This vulnerability had been patched in Apache James 3.6.1 and higher. We recommend the upgrade. Distributed and Cassandra based products are also not impacted.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache James
PublishedJan 4, 2022
First seenJan 4, 2022
Weakness typeCWE-22Path traversal
How to fix
Update
- apache james3.6.2 or later
- org.apache.james:james-server3.6.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache james | v < 3.6.2 | 3.6.2 |
| org.apache.james:james-serverMaven | v < 3.6.1 | 3.6.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.