CVE-2021-40865

Critical

Description

An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Storm
PublishedOct 25, 2021
First seenOct 25, 2021

How to fix

Update
  • apache storm1.2.4, 2.1.1, 2.2.1 or later
  • org.apache.storm:storm2.2.1, 1.2.4, 2.1.1 or later

Affected products

ProductAffected versionsFixed in
apache storm1.0.0 ≤ v < 1.2.4, 2.1.0 ≤ v < 2.1.1, 2.2.0 ≤ v < 2.2.11.2.4, 2.1.1, 2.2.1
org.apache.storm:stormMaven2.2.0 ≤ v < 2.2.1, 1.0.0 ≤ v < 1.2.4, 2.1.0 ≤ v < 2.1.12.2.1, 1.2.4, 2.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.