CVE-2021-41086

High

Description

jsuites is an open source collection of common required javascript web components. In affected versions users are subject to cross site scripting (XSS) attacks via clipboard content. jsuites is vulnerable to DOM based XSS if the user can be tricked into copying _anything_ from a malicious and pasting it into the html editor. This is because a part of the clipboard content is directly written to `innerHTML` allowing for javascript injection and thus XSS. Users are advised to update to version 4.9.11 to resolve.

SeverityHigh
CVSS8.7
Exploit probability—
ProductJsuites
PublishedSep 21, 2021
First seenSep 21, 2021

How to fix

Update
  • jsuites jsuites4.9.11 or later
  • jsuites4.9.11 or later

Affected products

ProductAffected versionsFixed in
jsuites jsuitesv < 4.9.114.9.11
jsuitesnpmv < 4.9.114.9.11

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2021-41086 · Jsuites · Dark Radar