CVE-2021-41122

Medium

Description

Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has been resolved in version 0.3.0.

SeverityMedium
CVSS4.3
Exploit probability—
ProductVyper
PublishedOct 5, 2021
First seenOct 5, 2021
Weakness typeCWE-682CWE-682

How to fix

Update
  • vyperlang vyper0.3.0 or later
  • vyper0.3.0 or later

Affected products

ProductAffected versionsFixed in
vyperlang vyperv < 0.3.00.3.0
vyperPyPIv < 0.3.00.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.