CVE-2021-41125

Medium

Description

Scrapy is a high-level web crawling and scraping framework for Python. If you use `HttpAuthMiddleware` (i.e. the `http_user` and `http_pass` spider attributes) for HTTP authentication, all requests will expose your credentials to the request target. This includes requests generated by Scrapy components, such as `robots.txt` requests sent by Scrapy when the `ROBOTSTXT_OBEY` setting is set to `True`, or as requests reached through redirects. Upgrade to Scrapy 2.5.1 and use the new `http_auth_domain` spider attribute to control which domains are allowed to receive the configured HTTP authentication credentials. If you are using Scrapy 1.8 or a lower version, and upgrading to Scrapy 2.5.1 is not an option, you may upgrade to Scrapy 1.8.1 instead. If you cannot upgrade, set your HTTP authentication credentials on a per-request basis, using for example the `w3lib.http.basic_auth_header` function to convert your credentials into a value that you can assign to the `Authorization` header of your request, instead of defining your credentials globally using `HttpAuthMiddleware`.

SeverityMedium
CVSS5.7
Exploit probability—
ProductScrapy
PublishedOct 6, 2021
First seenOct 6, 2021

How to fix

Update
  • scrapy scrapy1.8.1, 2.5.1 or later
  • scrapy1.8.1, 2.5.1 or later

Affected products

ProductAffected versionsFixed in
scrapy scrapyv < 1.8.1, 2.0.0 ≤ v < 2.5.11.8.1, 2.5.1
debian debian_linux9.0—
scrapyPyPIv < 1.8.1, 2.0.0 ≤ v < 2.5.11.8.1, 2.5.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2021-41125 · Scrapy · Dark Radar