CVE-2021-41164
Description
CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.
How to fix
- ckeditor ckeditor4.17.0 or later
- drupal drupal8.9.20, 9.1.14, 9.2.9 or later
- oracle application_express22.1 or later
- ckeditor44.17.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ckeditor ckeditor | 4.0 ≤ v < 4.17.0 | 4.17.0 |
| drupal drupal | 8.9.0 ≤ v < 8.9.20, 9.1.0 ≤ v < 9.1.14, 9.2.0 ≤ v < 9.2.9 | 8.9.20, 9.1.14, 9.2.9 |
| oracle banking_apis | 18.1 ≤ v ≤ 18.3, 19.1, 19.2, 20.1, 21.1 | — |
| oracle banking_digital_experience | 18.1 ≤ v ≤ 18.3, 19.1, 19.2, 20.1, 21.1 | — |
| oracle agile_product_lifecycle_management | 9.3.6 | — |
| oracle application_express | v < 22.1 | 22.1 |
| oracle commerce_guided_search | 11.3.2 | — |
| oracle peoplesoft_enterprise_peopletools | 8.58, 8.59 | — |
| oracle webcenter_portal | 12.2.1.3.0, 12.2.1.4.0 | — |
| fedoraproject fedora | 36, 37 | — |
| ckeditor4npm | v < 4.17.0 | 4.17.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.