CVE-2021-41177
Description
Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, Nextcloud Server did not implement a database backend for rate-limiting purposes. Any component of Nextcloud using rate-limits (as as `AnonRateThrottle` or `UserRateThrottle`) was thus not rate limited on instances not having a memory cache backend configured. In the case of a default installation, this would notably include the rate-limits on the two factor codes. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5, or 22.2.0. As a workaround, enable a memory cache backend in `config.php`.
How to fix
- nextcloud nextcloud_server20.0.13, 21.0.5, 22.2.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | v < 20.0.13, 21.0.0 ≤ v < 21.0.5, 22.0.0 ≤ v < 22.2.0 | 20.0.13, 21.0.5, 22.2.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.