CVE-2021-41182
Description
jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `altField` option of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `altField` option is now treated as a CSS selector. A workaround is to not accept the value of the `altField` option from untrusted sources.
How to fix
- jqueryui jquery_ui1.13.0 or later
- drupal drupal7.86 or later
- tenable tenable.sc5.21.0 or later
- oracle application_express22.1.1 or later
- oracle big_data_spatial_and_graph23.1 or later
- oracle rest_data_services22.1.1 or later
- jquery-ui1.13.0 or later
- jQuery.UI.Combined1.13.0 or later
- jquery-ui-rails7.0.0 or later
- org.webjars.npm:jquery-ui1.13.0 or later
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/O74SXYY7RGXREQDQUDQD4BPJ4QQTD2XQ/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SNXA7XRKGINWSUIPIZ6ZBCTV6N3KSHES/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NXIUUBRVLA4E7G7MMIKCEN75YN7UFERW/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4/
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| jqueryui jquery_ui | v < 1.13.0 | 1.13.0 |
| fedoraproject fedora | 33, 34, 35, 36 | — |
| netapp h500s_firmware | No range specified | — |
| netapp h700s_firmware | No range specified | — |
| netapp h300e_firmware | No range specified | — |
| netapp h500e_firmware | No range specified | — |
| netapp h700e_firmware | No range specified | — |
| netapp h410s_firmware | No range specified | — |
| netapp h410c_firmware | No range specified | — |
| netapp h300s_firmware | No range specified | — |
| debian debian_linux | 9.0 | — |
| drupal drupal | 7.0 ≤ v < 7.86 | 7.86 |
| oracle communications_interactive_session_recorder | 6.4 | — |
| oracle communications_operations_monitor | 4.3, 4.4, 5.0 | — |
| oracle hospitality_suite8 | 8.11.0 ≤ v ≤ 8.14.0, 8.10.2 | — |
| oracle mysql_enterprise_monitor | v ≤ 8.0.29 | — |
| oracle primavera_unifier | 17.7, 17.8, 17.9, 17.10, 17.11, 17.12, 18.8, 19.12, 20.12, 21.12, 17.7 ≤ v ≤ 17.12 | — |
| oracle weblogic_server | 12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0 | — |
| tenable tenable.sc | v < 5.21.0 | 5.21.0 |
| oracle agile_product_lifecycle_management | 9.3.6 | — |
| oracle application_express | v < 22.1.1 | 22.1.1 |
| oracle banking_platform | 2.9.0, 2.12.0 | — |
| oracle big_data_spatial_and_graph | v < 23.1, 23.1 | 23.1 |
| oracle hospitality_inventory_management | 9.1.0 | — |
| oracle hospitality_materials_control | 18.1 | — |
| oracle jd_edwards_enterpriseone_tools | v ≤ 9.2.6.3 | — |
| oracle peoplesoft_enterprise_peopletools | 8.58, 8.59 | — |
| oracle policy_automation | 12.2.0 ≤ v ≤ 12.2.25 | — |
| oracle rest_data_services | v < 22.1.1, 22.1.1 | 22.1.1 |
| jquery-uinpm | v < 1.13.0 | 1.13.0 |
| jQuery.UI.CombinedNuGet | v < 1.13.0 | 1.13.0 |
| jquery-ui-railsRubyGems | v < 7.0.0 | 7.0.0 |
| org.webjars.npm:jquery-uiMaven | v < 1.13.0 | 1.13.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.