CVE-2021-41264

Critical

Description

OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301).

SeverityCritical
CVSS9.8
Exploit probability—
ProductOpenzeppelin Contracts
PublishedNov 12, 2021
First seenNov 12, 2021
Weakness typeCWE-665CWE-665

How to fix

Update
  • openzeppelin contracts4.3.2 or later
  • @openzeppelin/contracts4.3.2 or later
  • @openzeppelin/contracts-upgradeable4.3.2 or later

Affected products

ProductAffected versionsFixed in
openzeppelin contracts4.1.0 ≤ v < 4.3.24.3.2
@openzeppelin/contractsnpm4.1.0 ≤ v < 4.3.24.3.2
@openzeppelin/contracts-upgradeablenpm4.1.0 ≤ v < 4.3.24.3.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.