CVE-2021-41303
Critical
Description
Apache Shiro before 1.8.0, when using Apache Shiro with Spring Boot, a specially crafted HTTP request may cause an authentication bypass. Users should update to Apache Shiro 1.8.0.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Shiro
PublishedSep 17, 2021
First seenSep 17, 2021
Weakness typeCWE-287Improper authentication
How to fix
Update
- apache shiro1.8.0 or later
- org.apache.shiro:shiro-core1.8.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache shiro | v < 1.8.0 | 1.8.0 |
| oracle financial_services_crime_and_compliance_management_studio | 8.0.8.2.0, 8.0.8.3.0 | — |
| org.apache.shiro:shiro-coreMaven | v < 1.8.0 | 1.8.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.