CVE-2021-4229
Medium
Description
A vulnerability was found in ua-parser-js 0.7.29/0.8.0/1.0.0. It has been rated as critical. This issue affects the crypto mining component which introduces a backdoor. Upgrading to version 0.7.30, 0.8.1 and 1.0.1 is able to address this issue. It is recommended to upgrade the affected component.
SeverityMedium
CVSS5.0
Exploit probability—
ProductUa-parser-js
PublishedMay 24, 2022
First seenMay 24, 2022
Weakness typeCWE-912CWE-912
How to fix
Update
- ua-parser-js0.7.30, 0.8.1, 1.0.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ua-parser-js_project ua-parser-js | 0.7.29, 0.8.0, 1.0.0 | — |
| ua-parser-jsnpm | 0.7.29 ≤ v < 0.7.30, 0.8.0 ≤ v < 0.8.1, 1.0.0 ≤ v < 1.0.1 | 0.7.30, 0.8.1, 1.0.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.