CVE-2021-4231

Low

Description

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.

SeverityLow
CVSS3.5
Exploit probability—
ProductAngular
PublishedMay 26, 2022
First seenMay 26, 2022

How to fix

Update
  • angularjs angularjs11.0.5 or later
  • @angular/core11.0.5, 11.1.0-next.3, 10.2.5 or later

Affected products

ProductAffected versionsFixed in
angular angular11.1.0—
angularjs angularjsv < 11.0.511.0.5
@angular/corenpm11.0.0 ≤ v < 11.0.5, 11.1.0-next.0 ≤ v < 11.1.0-next.3, v < 10.2.511.0.5, 11.1.0-next.3, 10.2.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.