CVE-2021-4259

Medium

Description

A vulnerability was found in phpRedisAdmin up to 1.16.1. It has been classified as problematic. This affects the function authHttpDigest of the file includes/login.inc.php. The manipulation of the argument response leads to use of wrong operator in string comparison. Upgrading to version 1.16.2 is able to address this issue. The name of the patch is 31aa7661e6db6f4dffbf9a635817832a0a11c7d9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216267.

SeverityMedium
CVSS5.0
Exploit probability—
ProductPhpredisadmin
PublishedDec 19, 2022
First seenDec 19, 2022
Weakness typeCWE-597CWE-597

How to fix

Affected products

ProductAffected versionsFixed in
phpredisadmin_project phpredisadminv < 1.16.21.16.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.