CVE-2021-4285

Low

Description

A vulnerability classified as problematic was found in Nagios NCPA. This vulnerability affects unknown code of the file agent/listener/templates/tail.html. The manipulation of the argument name leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 2.4.0 is able to address this issue. The name of the patch is 5abbcd7aa26e0fc815e6b2b0ffe1c15ef3e8fab5. It is recommended to upgrade the affected component. VDB-216874 is the identifier assigned to this vulnerability.

SeverityLow
CVSS3.5
Exploit probability—
ProductNagios Cross Platform Agent
PublishedDec 27, 2022
First seenDec 27, 2022

How to fix

Affected products

ProductAffected versionsFixed in
nagios nagios_cross_platform_agentv < 2.4.02.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.