CVE-2021-4303

Low

Description

A vulnerability, which was classified as problematic, has been found in shannah Xataface up to 2.x. Affected by this issue is the function testftp of the file install/install_form.js.php of the component Installer. The manipulation leads to cross site scripting. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 3.0.0 is able to address this issue. The patch is identified as 94143a4299e386f33bf582139cd4702571d93bde. It is recommended to upgrade the affected component. VDB-217442 is the identifier assigned to this vulnerability. NOTE: Installer is disabled by default.

SeverityLow
CVSS2.0
Exploit probability—
ProductXataface
PublishedJan 5, 2023
First seenJan 5, 2023

How to fix

Update
  • xataface_project xataface3.0.0 or later
  • xataface/xataface3.0.0 or later

Affected products

ProductAffected versionsFixed in
xataface_project xatafacev < 3.0.03.0.0
xataface/xatafacePackagistv < 3.0.03.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.