CVE-2021-4306

Low

Description

A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.

SeverityLow
CVSS3.5
Exploit probability—
ProductTerminal-kit
PublishedJan 7, 2023
First seenJan 7, 2023
Weakness typeCWE-1333CWE-1333

How to fix

Affected products

ProductAffected versionsFixed in
terminal-kit_project terminal-kitv < 2.1.82.1.8
terminal-kitnpmv < 2.1.82.1.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.