CVE-2021-4315

Medium

Description

A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.

SeverityMedium
CVSS5.5
Exploit probability—
ProductPsiturk
PublishedJan 28, 2023
First seenJan 28, 2023
Weakness typeCWE-1336CWE-1336

How to fix

Affected products

ProductAffected versionsFixed in
psiturk psiturkv < 3.2.13.2.1
psiturkPyPIv < 3.2.13.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.