CVE-2021-43789
High
Description
PrestaShop is an Open Source e-commerce web application. Versions of PrestaShop prior to 1.7.8.2 are vulnerable to blind SQL injection using search filters with `orderBy` and `sortOrder` parameters. The problem is fixed in version 1.7.8.2.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Prestashop
PublishedDec 7, 2021
First seenDec 7, 2021
Weakness typeCWE-89SQL injection
How to fix
Update
- prestashop prestashop1.7.8.2 or later
- prestashop/prestashop1.7.8.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| prestashop prestashop | 1.7.5.0 ≤ v < 1.7.8.2 | 1.7.8.2 |
| prestashop/prestashopPackagist | 1.7.5.0 ≤ v < 1.7.8.2 | 1.7.8.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.