CVE-2021-43808
Description
Laravel is a web application framework. Laravel prior to versions 8.75.0, 7.30.6, and 6.20.42 contain a possible cross-site scripting (XSS) vulnerability in the Blade templating engine. A broken HTML element may be clicked and the user taken to another location in their browser due to XSS. This is due to the user being able to guess the parent placeholder SHA-1 hash by trying common names of sections. If the parent template contains an exploitable HTML structure an XSS vulnerability can be exposed. This vulnerability has been patched in versions 8.75.0, 7.30.6, and 6.20.42 by determining the parent placeholder at runtime and using a random hash that is unique to each request.
How to fix
- laravel framework6.20.42, 7.30.6, 8.75.0 or later
- laravel/framework6.20.42, 7.30.6, 8.75.0 or later
- illuminate/view6.20.42, 7.30.6, 8.75.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| laravel framework | v < 6.20.42, 7.0.0 ≤ v < 7.30.6, 8.0.0 ≤ v < 8.75.0 | 6.20.42, 7.30.6, 8.75.0 |
| laravel/frameworkPackagist | v < 6.20.42, 7.0.0 ≤ v < 7.30.6, 8.0.0 ≤ v < 8.75.0 | 6.20.42, 7.30.6, 8.75.0 |
| illuminate/viewPackagist | v < 6.20.42, 7.0.0 ≤ v < 7.30.6, 8.0.0 ≤ v < 8.75.0 | 6.20.42, 7.30.6, 8.75.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.