CVE-2021-43836
Description
Sulu is an open-source PHP content management system based on the Symfony framework. In affected versions an attacker can read arbitrary local files via a PHP file include. In a default configuration this also leads to remote code execution. The problem is patched with the Versions 1.6.44, 2.2.18, 2.3.8, 2.4.0. For users unable to upgrade overwrite the service `sulu_route.generator.expression_token_provider` and wrap the translator before passing it to the expression language.
How to fix
- sulu sulu1.6.44, 2.2.18, 2.3.8 or later
- sulu/sulu1.6.44, 2.2.18, 2.3.8, 2.4.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| sulu sulu | v < 1.6.44, 2.0.0 ≤ v < 2.2.18, 2.3.0 ≤ v < 2.3.8, 2.4.0 | 1.6.44, 2.2.18, 2.3.8 |
| sulu/suluPackagist | v < 1.6.44, 2.0.0 ≤ v < 2.2.18, 2.3.0 ≤ v < 2.3.8, 2.4.0-RC1 ≤ v < 2.4.0 | 1.6.44, 2.2.18, 2.3.8, 2.4.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.