CVE-2021-43850

Medium

Description

Discourse is an open source platform for community discussion. In affected versions admins users can trigger a Denial of Service attack via the `/message-bus/_diagnostics` path. The impact of this vulnerability is greater on multisite Discourse instances (where multiple forums are served from a single application server) where any admin user on any of the forums are able to visit the `/message-bus/_diagnostics` path. The problem has been patched. Please upgrade to 2.8.0.beta10 or 2.7.12. No workarounds for this issue exist.

SeverityMedium
CVSS6.8
Exploit probability—
ProductDiscourse
PublishedJan 4, 2022
First seenJan 4, 2022

How to fix

Update
  • discourse discourse2.7.12 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 2.7.12, 2.8.02.7.12

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.