CVE-2021-43862

Low

Description

jQuery Terminal Emulator is a plugin for creating command line interpreters in your applications. Versions prior to 2.31.1 contain a low impact and limited cross-site scripting (XSS) vulnerability. The code for XSS payload is always visible, but an attacker can use other techniques to hide the code the victim sees. If the application uses the `execHash` option and executes code from URL, the attacker can use this URL to execute their code. The scope is limited because the javascript attribute used is added to span tag, so no automatic execution like with `onerror` on images is possible. This issue is fixed in version 2.31.1. As a workaround, the user can use formatting that wrap whole user input and its no op. The code for this workaround is available in the GitHub Security Advisory. The fix will only work when user of the library is not using different formatters (e.g. to highlight code in different way).

SeverityLow
CVSS3.7
Exploit probability—
ProductJquery.terminal
PublishedDec 30, 2021
First seenDec 30, 2021
Weakness typeCWE-80CWE-80

How to fix

Update
  • jquery.terminal_project jquery.terminal2.31.1 or later
  • jquery.terminal2.31.1 or later

Affected products

ProductAffected versionsFixed in
jquery.terminal_project jquery.terminalv < 2.31.12.31.1
jquery.terminalnpmv < 2.31.12.31.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.