CVE-2021-44451
Medium
Description
Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Superset
PublishedFeb 1, 2022
First seenFeb 1, 2022
Weakness typeCWE-522CWE-522
How to fix
Update
- apache-superset1.4.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache superset | v ≤ 1.3.2 | — |
| apache-supersetPyPI | v < 1.4.0 | 1.4.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.