CVE-2022-0758
Low
Description
Rapid7 Nexpose versions 6.6.129 and earlier suffer from a reflected cross site scripting vulnerability, within the shared scan configuration component of the tool. With this vulnerability an attacker could pass literal values as the test credentials, providing the opportunity for a potential XSS attack. This issue is fixed in Rapid7 Nexpose version 6.6.130.
SeverityLow
CVSS3.3
Exploit probability—
ProductRapid7 Nexpose
PublishedMar 17, 2022
First seenMar 17, 2022
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- rapid7 nexpose6.6.130 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| rapid7 nexpose | v < 6.6.130 | 6.6.130 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.