CVE-2022-21642
Medium
Description
Discourse is an open source platform for community discussion. In affected versions when composing a message from topic the composer user suggestions reveals whisper participants. The issue has been patched in stable version 2.7.13 and beta version 2.8.0.beta11. There is no workaround for this issue and users are advised to upgrade.
SeverityMedium
CVSS4.3
Exploit probability—
Product
Discourse
PublishedJan 5, 2022
First seenJan 5, 2022
Weakness typeCWE-200Sensitive information exposure
How to fix
Update
- discourse discourse2.7.13 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| discourse discourse | v < 2.7.13, 2.8.0 | 2.7.13 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.