CVE-2022-21647

High

Description

CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.

SeverityHigh
CVSS7.7
Exploit probability—
ProductCodeigniter
PublishedJan 4, 2022
First seenJan 4, 2022

How to fix

Update
  • codeigniter codeigniter4.1.6 or later
  • codeigniter4/framework4.1.6 or later

Affected products

ProductAffected versionsFixed in
codeigniter codeigniter4.0.0 ≤ v < 4.1.64.1.6
codeigniter4/frameworkPackagistv < 4.1.64.1.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2022-21647 · Codeigniter · Dark Radar