CVE-2022-21659

Medium

Description

Flask-AppBuilder is an application development framework, built on top of the Flask web framework. In affected versions there exists a user enumeration vulnerability. This vulnerability allows for a non authenticated user to enumerate existing accounts by timing the response time from the server when you are logging in. Users are advised to upgrade to version 3.4.4 as soon as possible. There are no known workarounds for this issue.

SeverityMedium
CVSS5.3
Exploit probability—
ProductDpgaspar Flask-appbuilder
PublishedJan 31, 2022
First seenJan 31, 2022
Weakness typeCWE-203CWE-203

How to fix

Update
  • dpgaspar flask-appbuilder3.4.2 or later
  • flask-appbuilder3.4.4, 3.4.2 or later

Affected products

ProductAffected versionsFixed in
dpgaspar flask-appbuilderv < 3.4.23.4.2
flask-appbuilderPyPIv < 3.4.4, v < 3.4.23.4.4, 3.4.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.