CVE-2022-21661
Description
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.
How to fix
- wordpress wordpress3.7.37, 3.8.37, 3.9.35, 4.0.34, 4.1.34, 4.2.31, 4.3.27, 4.4.26, 4.5.25, 4.6.22, 4.7.22, 4.8.18, 4.9.19, 5.0.15, 5.1.12, 5.2.14, 5.3.11, 5.4.9, 5.5.8, 5.6.7, 5.7.5, 5.8.3 or later
- wordpress.org/news/2022/01/wordpress-5-8-3-security-release/
- debian.org/security/2022/dsa-5039
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DM6XPH3JN6V4NF4WBOJTOXZIVE6VKKE3/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CV4UNEC63UU5GEU47IIR4RMTZAHNEOJG/
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| wordpress wordpress | 3.7 ≤ v < 3.7.37, 3.8 ≤ v < 3.8.37, 3.9 ≤ v < 3.9.35, 4.0 ≤ v < 4.0.34, 4.1 ≤ v < 4.1.34, 4.2 ≤ v < 4.2.31, 4.3 ≤ v < 4.3.27, 4.4 ≤ v < 4.4.26, 4.5 ≤ v < 4.5.25, 4.6 ≤ v < 4.6.22, 4.7 ≤ v < 4.7.22, 4.8 ≤ v < 4.8.18, 4.9 ≤ v < 4.9.19, 5.0 ≤ v < 5.0.15, 5.1 ≤ v < 5.1.12, 5.2 ≤ v < 5.2.14, 5.3 ≤ v < 5.3.11, 5.4 ≤ v < 5.4.9, 5.5 ≤ v < 5.5.8, 5.6 ≤ v < 5.6.7, 5.7 ≤ v < 5.7.5, 5.8 ≤ v < 5.8.3 | 3.7.37, 3.8.37, 3.9.35, 4.0.34, 4.1.34, 4.2.31, 4.3.27, 4.4.26, 4.5.25, 4.6.22, 4.7.22, 4.8.18, 4.9.19, 5.0.15, 5.1.12, 5.2.14, 5.3.11, 5.4.9, 5.5.8, 5.6.7, 5.7.5, 5.8.3 |
| fedoraproject fedora | 34, 35 | — |
| debian debian_linux | 9.0, 10.0, 11.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.