CVE-2022-21664

High

Description

WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to lack of proper sanitization in one of the classes, there's potential for unintended SQL queries to be executed. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 4.1.34. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.

SeverityHigh
CVSS7.4
Exploit probability90. percentile3.7%
ProductWordpress
PublishedJan 6, 2022
First seenJan 6, 2022
Weakness typeCWE-89SQL injection

How to fix

Affected products

ProductAffected versionsFixed in
wordpress wordpressv < 5.8.35.8.3
debian debian_linux9.0, 10.0, 11.0—
fedoraproject fedora34, 35—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2022-21664 · Wordpress · Dark Radar