CVE-2022-21708

Medium

Description

graphql-go is a GraphQL server with a focus on ease of use. In versions prior to 1.3.0 there exists a DoS vulnerability that is possible due to a bug in the library that would allow an attacker with specifically designed queries to cause stack overflow panics. Any user with access to the GraphQL handler can send these queries and cause stack overflows. This in turn could potentially compromise the ability of the server to serve data to its users. The issue has been patched in version `v1.3.0`. The only known workaround for this issue is to disable the `graphql.MaxDepth` option from your schema which is not recommended.

SeverityMedium
CVSS6.5
Exploit probability—
ProductGraphql-go
PublishedJan 21, 2022
First seenJan 21, 2022

How to fix

Update
  • graphql-go_project graphql-go1.3.0 or later
  • github.com/graph-gophers/graphql-go1.3.0 or later

Affected products

ProductAffected versionsFixed in
graphql-go_project graphql-gov < 1.3.01.3.0
github.com/graph-gophers/graphql-goGov < 1.3.01.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.