CVE-2022-2196
Description
A regression exists in the Linux Kernel within KVM: nVMX that allowed for speculative execution attacks. L2 can carry out Spectre v2 attacks on L1 due to L1 thinking it doesn't need retpolines or IBPB after running L2 due to KVM (L0) advertising eIBRS support to L1. An attacker at L2 with code execution can execute code on an indirect branch on the host machine. We recommend upgrading to Kernel 6.2 or applying the relevant stable backports (v5.4.233, v5.10.170, v5.15.96, v6.1.14).
How to fix
- linux linux_kernel5.4.233, 5.7, 5.10.170, 5.15.96, 6.1.14 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| linux linux_kernel | 5.4.47 ≤ v < 5.4.233, 5.6.19 ≤ v < 5.7, 5.7.3 ≤ v < 5.10.170, 5.11 ≤ v < 5.15.96, 5.16 ≤ v < 6.1.14 | 5.4.233, 5.7, 5.10.170, 5.15.96, 6.1.14 |
| debian debian_linux | 10.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.