CVE-2022-23094
High
Description
Libreswan 4.2 through 4.5 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted IKEv1 packet because pluto/ikev1.c wrongly expects that a state object exists. This is fixed in 4.6.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Libreswan
PublishedJan 15, 2022
First seenJan 15, 2022
How to fix
Update
- libreswan libreswan4.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| libreswan libreswan | 4.2 ≤ v < 4.6 | 4.6 |
| fedoraproject fedora | 34, 35 | — |
| debian debian_linux | 10.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.