CVE-2022-23223
High
Description
On Apache ShenYu versions 2.4.0 and 2.4.1, and endpoint existed that disclosed the passwords of all users. Users are recommended to upgrade to version 2.4.2 or later.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Shenyu
PublishedJan 25, 2022
First seenJan 25, 2022
Weakness typeCWE-522CWE-522
How to fix
Update
- org.apache.shenyu:shenyu-common2.4.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache shenyu | 2.4.0, 2.4.1 | — |
| org.apache.shenyu:shenyu-commonMaven | 2.4.0 ≤ v < 2.4.2 | 2.4.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.