CVE-2022-23487

High

Description

js-libp2p is the official javascript Implementation of libp2p networking stack. Versions older than `v0.38.0` of js-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of js-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. Users are advised to update their js-libp2p dependency to `v0.38.0` or greater. There are no known workarounds for this vulnerability.

SeverityHigh
CVSS7.5
Exploit probability—
ProductProtocol Libp2p
PublishedDec 7, 2022
First seenDec 7, 2022

How to fix

Update
  • protocol libp2p0.38.0 or later
  • libp2p0.38.0 or later

Affected products

ProductAffected versionsFixed in
protocol libp2pv < 0.38.00.38.0
libp2pnpmv < 0.38.00.38.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.