CVE-2022-23501
Description
TYPO3 is an open source PHP based web content management system. In versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 TYPO3 is vulnerable to Improper Authentication. Restricting frontend login to specific users, organized in different storage folders (partitions), can be bypassed. A potential attacker might use this ambiguity in usernames to get access to a different account - however, credentials must be known to the adversary. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.
How to fix
- typo3 typo38.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 or later
- typo3/cms-core8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 or later
- typo3/cms10.4.33, 11.5.20, 12.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| typo3 typo3 | v < 8.7.49, 9.0.0 ≤ v < 9.5.38, 10.0.0 ≤ v < 10.4.33, 11.0.0 ≤ v < 11.5.20, 12.0.0 ≤ v < 12.1.1 | 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
| typo3/cms-corePackagist | v < 8.7.49, 9.0.0 ≤ v < 9.5.38, 10.0.0 ≤ v < 10.4.33, 11.0.0 ≤ v < 11.5.20, 12.0.0 ≤ v < 12.1.1 | 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
| typo3/cmsPackagist | 10.0.0 ≤ v < 10.4.33, 11.0.0 ≤ v < 11.5.20, 12.0.0 ≤ v < 12.1.1 | 10.4.33, 11.5.20, 12.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.