CVE-2022-23503
Description
TYPO3 is an open source PHP based web content management system. Versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are vulnerable to Code Injection. Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it is possible to inject code instructions to be processed and executed via TypoScript as PHP code. The existence of individual TypoScript instructions for a particular form item and a valid backend user account with access to the form module are needed to exploit this vulnerability. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.
How to fix
- typo3 typo38.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 or later
- typo3/cms-core8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 or later
- typo3/cms10.4.33, 11.5.20, 12.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| typo3 typo3 | 8.0.0 ≤ v < 8.7.49, 9.0.0 ≤ v < 9.5.38, 10.0.0 ≤ v < 10.4.33, 11.0.0 ≤ v < 11.5.20, 12.0.0 ≤ v < 12.1.1 | 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
| typo3/cms-corePackagist | 8.0.0 ≤ v < 8.7.49, 9.0.0 ≤ v < 9.5.38, 10.0.0 ≤ v < 10.4.33, 11.0.0 ≤ v < 11.5.20, 12.0.0 ≤ v < 12.1.1 | 8.7.49, 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
| typo3/cmsPackagist | 10.0.0 ≤ v < 10.4.33, 11.0.0 ≤ v < 11.5.20, 12.0.0 ≤ v < 12.1.1 | 10.4.33, 11.5.20, 12.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.