CVE-2022-23504
Description
TYPO3 is an open source PHP based web content management system. Versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are subject to Sensitive Information Disclosure. Due to the lack of handling user-submitted YAML placeholder expressions in the site configuration backend module, attackers could expose sensitive internal information, such as system configuration or HTTP request messages of other website visitors. A valid backend user account having administrator privileges is needed to exploit this vulnerability. This issue has been patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.
How to fix
- typo3 typo39.5.38, 10.4.33, 11.5.20, 12.1.1 or later
- typo3/cms-core9.5.38, 10.4.33, 11.5.20, 12.1.1 or later
- typo3/cms10.4.33, 11.5.20, 12.1.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| typo3 typo3 | 9.0.0 ≤ v < 9.5.38, 10.0.0 ≤ v < 10.4.33, 11.0.0 ≤ v < 11.5.20, 12.0.0 ≤ v < 12.1.1 | 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
| typo3/cms-corePackagist | 9.0.0 ≤ v < 9.5.38, 10.0.0 ≤ v < 10.4.33, 11.0.0 ≤ v < 11.5.20, 12.0.0 ≤ v < 12.1.1 | 9.5.38, 10.4.33, 11.5.20, 12.1.1 |
| typo3/cmsPackagist | 10.0.0 ≤ v < 10.4.33, 11.0.0 ≤ v < 11.5.20, 12.0.0 ≤ v < 12.1.1 | 10.4.33, 11.5.20, 12.1.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.