CVE-2022-23515
Medium
Description
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.
SeverityMedium
CVSS6.1
Exploit probability—
Product
Loofah
PublishedDec 14, 2022
First seenDec 14, 2022
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- loofah_project loofah2.19.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| loofah_project loofah | 2.1.0 ≤ v < 2.19.1 | 2.19.1 |
| debian debian_linux | 10.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.