CVE-2022-23518
Medium
Description
rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Versions >= 1.0.3, < 1.4.4 are vulnerable to cross-site scripting via data URIs when used in combination with Loofah >= 2.1.0. This issue is patched in version 1.4.4.
SeverityMedium
CVSS6.1
Exploit probability—
Product
Rubyonrails Rails Html Sanitizers
PublishedDec 14, 2022
First seenDec 14, 2022
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- rubyonrails rails_html_sanitizers1.4.4 or later
- loofah_project loofah2.19.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| rubyonrails rails_html_sanitizers | 1.0.3 ≤ v < 1.4.4 | 1.4.4 |
| debian debian_linux | 10.0 | — |
| loofah_project loofah | 2.1.0 ≤ v < 2.19.1 | 2.19.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.